Azion
Console Community

Performance Issues in Edge Orchestration

Incident Report for Azion

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 18:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2026 - 17:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 11, 2026 - 17:52 UTC

Investigating

We are currently under performance issues on our Orchestration platform. During this period, operations such as adding, removing, or editing Azion products via Console, CLI or API may take longer than usual, or return errors.

All services that are accessible to end-users remain fully active and 100% functional. The impact is limited solely to the processing of new changes.
Posted Mar 11, 2026 - 17:40 UTC
This incident affected: Application Development & Hosting (Orchestrator).