Issue Affecting New Certificate Issuance in Certificate Manager

Incident Report for Azion Technologies

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 14:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2025 - 03:05 UTC

Investigating

We experienced an issue in Certificate Manager that affected the issuance of new certificates.
Existing certificates and their renewals were not impacted.
Posted Sep 13, 2025 - 01:57 UTC
This incident affected: Edge Services (Digital Certificates).