Azion
Console Community

Performance Issues in DNS services

Incident Report for Azion

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 14:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 13:18 UTC

Investigating

We are currently experiencing a partial disruption affecting our DNS services, which may impact domain resolution for a subset of customers in Europe, the United States, and Argentina.

Our Engineering team is actively investigating the issue and working to restore full service stability as quickly as possible. We will continue to provide timely updates as additional information becomes available.
Posted Feb 25, 2026 - 12:52 UTC
This incident affected: Application & Network Security (Edge DNS).