Azion
Console Community

Performance Issues in Data Services

Incident Report for Azion

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 03:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2026 - 21:40 UTC

Identified

We have identified a recurrence of processing delays affecting Data Services. Our team has identified the cause and is actively working on a fix.
Posted Jun 24, 2026 - 17:32 UTC

Monitoring

A fix has been implemented and data processing has fully caught up. The backlog that accumulated during the incident has been drained, and data processing and update propagation have returned to normal levels. We are now monitoring the affected services to ensure stability before marking this incident as resolved.
Posted Jun 24, 2026 - 15:42 UTC

Update

The fix remains in place and the backlog has started to decrease. Data processing is steadily catching up, though some delay in data processing and update propagation may still be observed until the queues are fully drained. Our team continues to monitor the recovery closely and will provide further updates as processing returns to normal.
Posted Jun 24, 2026 - 13:12 UTC

Update

The fix remains in place and data processing continues to recover. We are still working through the backlog that built up during the incident, so some delay in data processing and update propagation may persist while the queues drain. Our team continues to monitor progress closely and will provide further updates as the backlog clears.
Posted Jun 24, 2026 - 12:20 UTC

Update

A fix has been implemented and data processing has resumed. A backlog accumulated during the incident is still being processed, so delays in data processing and update propagation are still expected while the queues drain. We continue to actively monitor the recovery until processing fully catches up.
Posted Jun 24, 2026 - 10:54 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 23:14 UTC

Investigating

We are currently experiencing delays in data updates within Data Services, impacting the Data Stream, Real-Time Events, and Real-Time Metrics products. Users may notice delayed data processing and slower propagation of updates. Our team is actively investigating and working on mitigation.
Posted Jun 23, 2026 - 23:12 UTC
This incident affected: Application Observability (Data Stream, Real-Time Events, Real-Time Metrics).