Performance Issues on Orchestration Platform

Incident Report for Azion Technologies

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 20:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 16:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 31, 2025 - 15:53 UTC

Investigating

We are currently under performance issues on our Orchestration platform. Operations such as adding, removing, or editing Azion products via Console or API may take longer than usual or return errors. Please be assured that no changes will be lost.
Posted Mar 31, 2025 - 15:35 UTC
This incident affected: Management & APIs (APIs, Azion Console).