Performance issues on Analytics
Incident Report for Azion Technologies
Resolved
This incident has been resolved.
Posted Aug 18, 2017 - 00:03 UTC
Identified
We've identified the problem on Analytics and we're working on it.
Posted Aug 17, 2017 - 17:55 UTC